Troubleshooting WordPress Errors
If you don't see your error below, please email us at hello@koala.sh and provide details about your error.
Note: We can't integrate to sites hosted by WordPress.com since they don't support WordPress' built-in Application Passwords. This is not a bug.
Error message:
Solutions:
1) Please try adding the integration again using your email address instead of the username. This often fixes the problem
2) If the above does not work, try going to the Permalink settings inside WordPress and clicking Save (without changing anything). This is often needed on brand new websites and is known as permalink flushing
3) If it is still not working, please make sure that you do not have any plugins that might be restricting access to the API
This is usually caused by entering the incorrect WordPress Site Domain.
For example, if your homepage is example.com then you must put example.com.
If you have a custom login page you still must put example.com. Do not enter the address of your login page.
If WordPress is installed in a subdirectory such as example.com/guides then you should enter example.com/guides as the WordPress Site Domain.
This usually happens if your firewall (such as Cloudflare) or your server is blocking our connection.
Please whitelist our user agent KoalaWriter/1.0 (https://koala.sh/writer) and it should work.
Error message:
500: {"code":"incorrect_password","message":"<strong>Error:<\/strong> The password you entered for the username <strong>koala283<\/strong> is incorrect. <a href=\"https:\/\/domain\/wp-login.php?action=lostpassword\">Lost your password?<\/a>","data":null}
Cause:
This error is caused by using EasyWP hosting or a plugin that breaks the built-in API authentication.
Solution:
If you are using EasyWP, you must install the Application Passwords plugin. For some reason, this host breaks the built-in API and refuses to fix the problem.
Otherwise, if you have a plugin that changes how the API authentication works installed, please deactivate it and try clicking the Create Draft button again. This should work after that.
Known plugin conflicts:
- Basic API Authentication plugin
- JSON Basic Authentication plugin
These are outdated plugins that should no longer be installed.
Error message:
Cause:
Your server redirects us when we create the WordPress draft on your domain. This could happen if your domain is set to redirect to either the non-www or www version and the incorrect one was entered.
Solution:
1) If your domain is set to redirect to the www version, please disconnect the WordPress integration on your Koala account and reconnect it using the www version.
2) If your domain is set to redirect to the non-www version, please disconnect the WordPress integration on your Koala account and reconnect it using the non-www version
Error message:
Cause:
If you have the Wordfence plugin installed, it disables Application Passwords by default.
Solution:
Please go to Wordfence > All Options > Disable WordPress application passwords and make sure that Application Passwords are enabled.
Note: We can't integrate to sites hosted by WordPress.com since they don't support WordPress' built-in Application Passwords. This is not a bug.
401 Error Code
Error message:
Solutions:
1) Please try adding the integration again using your email address instead of the username. This often fixes the problem
2) If the above does not work, try going to the Permalink settings inside WordPress and clicking Save (without changing anything). This is often needed on brand new websites and is known as permalink flushing
3) If it is still not working, please make sure that you do not have any plugins that might be restricting access to the API
404 Error Code
This is usually caused by entering the incorrect WordPress Site Domain.
For example, if your homepage is example.com then you must put example.com.
If you have a custom login page you still must put example.com. Do not enter the address of your login page.
If WordPress is installed in a subdirectory such as example.com/guides then you should enter example.com/guides as the WordPress Site Domain.
429 or 403 Error Code
This usually happens if your firewall (such as Cloudflare) or your server is blocking our connection.
Please whitelist our user agent KoalaWriter/1.0 (https://koala.sh/writer) and it should work.
500 Error Code
Error message:
500: {"code":"incorrect_password","message":"<strong>Error:<\/strong> The password you entered for the username <strong>koala283<\/strong> is incorrect. <a href=\"https:\/\/domain\/wp-login.php?action=lostpassword\">Lost your password?<\/a>","data":null}
Cause:
This error is caused by using EasyWP hosting or a plugin that breaks the built-in API authentication.
Solution:
If you are using EasyWP, you must install the Application Passwords plugin. For some reason, this host breaks the built-in API and refuses to fix the problem.
Otherwise, if you have a plugin that changes how the API authentication works installed, please deactivate it and try clicking the Create Draft button again. This should work after that.
Known plugin conflicts:
- Basic API Authentication plugin
- JSON Basic Authentication plugin
These are outdated plugins that should no longer be installed.
"Your server returned an unexpected response"
Error message:
Your server returned an unexpected response when we tried to create a draft using the built-in WordPress API. Likely you have a plugin that has disabled the API, or you are redirecting the API route. You need to check your plugins and ensure nothing is interfering with the API. Your server returned a 200 code and the following response:...
Cause:
Your server redirects us when we create the WordPress draft on your domain. This could happen if your domain is set to redirect to either the non-www or www version and the incorrect one was entered.
Solution:
1) If your domain is set to redirect to the www version, please disconnect the WordPress integration on your Koala account and reconnect it using the www version.
2) If your domain is set to redirect to the non-www version, please disconnect the WordPress integration on your Koala account and reconnect it using the non-www version
Application Passwords have been disabled by Wordfence
Error message:
Cause:
If you have the Wordfence plugin installed, it disables Application Passwords by default.
Solution:
Please go to Wordfence > All Options > Disable WordPress application passwords and make sure that Application Passwords are enabled.
Updated on: 17/07/2024
Thank you!